Home » How-To » Gaming » How to Fix Outdated Client in Minecraft

How to Fix Outdated Client in Minecraft

Are you getting an “Outdated client” error in Minecraft?

Here’s the full error message, “Could not connect: Outdated client!”.

The error message typically happens on MCPE (Minecraft Pocket Edition).

MCPE is the mobile version of Minecraft, also known as Minecraft Bedrock.

However, the error can also happen on the PC and Xbox versions of Minecraft.

In this guide, you’ll learn what an Outdated Client means in Minecraft PE, PC, or Xbox, and how to fix it.

What does Outdated Client mean?

Could Not Connect Outdated Client

Outdated Client in Minecraft means that you’re using an older version of Minecraft.

This usually happens because you haven’t updated Minecraft to the latest version.

When you’re using an older version of Minecraft, you won’t be able to access certain servers.

This is because those servers are on the latest version of Minecraft and the version that you’re on is not compatible with it.

If you’re playing Minecraft PE, the app will be automatically updated if you’re on Wi-Fi.

However, if you’re not using Wi-Fi, the app might not update.

Hence, it can cause a connection issue when you try accessing a server.

Fortunately, this can be fixed with a few easy steps.

How to fix Outdated Client in Minecraft

To fix an Outdated Client in Minecraft, you need to first update the app to the latest version.

After you’ve updated Minecraft to the latest version, you need to change and enable certain settings in the app.

To do so, open Minecraft PE/Bedrock and tap on “Settings”.

In your settings, scroll down and tap on “Profile”.

Under “Auto Update Unlocked Packs”, select “On with Wi-Fi or Cellular data”.

You also need to enable “Use Cellular Data”, “Require Encrypted Websockets”, and “Only Allow Trusted Skins”.

Lastly, try joining the server again and see if the “Could not connect: Outdated client!” is fixed.

1. Update Minecraft to the latest version

Firstly, you need to make sure that Minecraft is updated to the latest version.

To check, you need to open the App Store or Google Play Store and search for “Minecraft”.

If there’s an update, you’ll see an “Update” button.

Tap on “Update” to update Minecraft to the latest version.

If Minecraft is not updated to the latest version, you won’t be able to join certain servers.

This is because your Minecraft version will not be compatible with the server.

You can also update Minecraft to the latest version by uninstalling and reinstalling it.

By doing so, the app’s cache will also be cleared.

2. Go to your settings

After you’ve updated Minecraft to the latest version, you need to go to your settings.

Firstly, open the Minecraft app on your mobile device.

Now, you’ll see a couple of buttons including “Play” and “Settings”.

Tap on “Settings” to go to your settings.

3. Enable these options

How to fix Outdated Client in Minecraft PE

After you’ve tapped on “Settings”, you’ll land on the settings page.

On the left sidebar, you’ll see multiple settings.

This includes “Accessibility”, “Controller”, “Profile”, and more.

Now, you need to modify certain profile options.

To do so, scroll down the left sidebar and tap on “Profile” under “General”.

In your profile settings, you’ll see an “Auto Update Unlocked Packs” dropdown box.

Tap on the dropdown box and select “On with Wi-Fi or Cellular Data”.

This will auto-update unlocked packs even if you’re not connected to a Wi-Fi network.

You also need to enable “Use Cellular Data”, “Require Encrypted Websockets”, and “Only Allow Trusted Skins”.

After you’ve enabled “Use Cellular Data”, a pop-up message will appear where you’ll have to agree.

Here’s what it says, “Playing over cellular network may incur additional charges with your carrier”.

Here’s how your profile settings should be configured:

User Profile and SettingsOn/Off
Auto Update Unlocked PacksOn with Wi-Fi or Cellular Data
Use Cellular DataOn
Require Encrypted WebsocketsOn
Only Allow Trusted SkinsOn

Once you’ve configured your user profile and settings like the table above, try joining the server again.

This time, you should be able to join the server without getting the “Outdated Client” error.

Minecraft Outdated Client on Xbox

The “Could not connect: Outdated client!” error can also happen on various devices like PC and Xbox.

If you’re encountering the error on your Xbox and you’re trying to join your friend’s world, you need to check both your and your friend’s Minecraft version.

If you or your friend is in the beta program/Minecraft Preview, connection issues can happen.

To fix the issue, both of you need to be using the same version of Minecraft.

You can leave the beta program by installing the Xbox Insider Hub app > Previews > Minecraft Preview.

Get additional help from Minecraft

If all else fails, you can try getting help from Minecraft.

To do so, navigate to the “Submit a request” page: https://help.minecraft.net/hc/en-us/requests/new.

Once you’re on the page, select your language, the game title, platform, and category.

You also need to provide your contact information like your name and email address.

Lastly, explain the issue that you’re facing, submit the form, and wait for Minecraft’s response.

Further reading

200+ Stardew Valley Farm Names

75+ Good Minecraft Server Rules

How to Fix “Multiplayer is disabled” in Minecraft

Tags

About the author

Lim How Wei

Lim How Wei is the founder of followchain.org, with 8+ years of experience in Social Media Marketing and 4+ years of experience as an active investor in stocks and cryptocurrencies. He has researched, tested, and written hundreds of articles ranging from social media platforms to messaging apps.